Amp problems

In car entertainment: stereo; speakers; portable devices etc

Moderator:Scirocco Register

G Beats
Posts:1050
Joined:Sun Jun 21, 2009 12:19 am
fill in the right answer:10
Amp problems

Post by G Beats » Wed Feb 16, 2011 6:43 am

Hi can anybody help me please ? I have 1of these amps--

http://www.crutchfield.com/S-icsgNEsvfl ... -F240.html

and on the 8/2/11 it got wet though me open the boot ' rain had got it wet but noticed this on the 14/2/11 it was only rain splash not really wet and rain splash on the wheel arch as well' i dryed all this off with paper tishu' i have 6x9s and a base box running off it and the other 4 car speakers running off the head unit' the power light is on the amp' and only 1 6x9 works' i think the bit of rain that got on it has shorted it out as in the amp? some has told me it needs to dry out ? this ok to leave in the car with the heater on or does amp need to come our rocco to do this?


All so will this amp if it works again will it run both of these ok-----

http://www.crutchfield.com/S-icsgNEsvfl ... -F240.html

http://www.caraudiodiscount.com/speaker ... 11859.html

http://www.priceleap.com/description/Al ... 1--5679727

http://uk.shopping.com/Alpine-SWE-1241/info



if not will this be ok to go on the side of my bass box here----

http://www.caraudiocentre.co.uk/product ... -23073.htm

bass box here---


http://www.caraudiocentre.co.uk/product ... -20685.htm

iam sure the other amp the jbl 1 will what i want it to ?

Can you help me please? many than'x.



Chaps
Posts:591
Joined:Thu Apr 16, 2009 10:03 am
fill in the right answer:10
Location:Preston

Re: Amp problems

Post by Chaps » Wed Feb 16, 2011 4:35 pm

Few questions:
1, how wet did the amp get exactly? there is a big difference between a small splash (drops) and a big splash (bucket full)?
2, was the amp on at the time that it got wet?
3, was the setup working 100% before it got wet?
4, how is the amp currently wired up? do you got a photo of your set up you can put up.


As to the products you've put together below (including new JBL amp)... yes it will all work together but your amp would be running at max output. You need to measure your sub box to make sure the amp will be able to mount on it, from looking it should fit on it somehow (maybe on the back of it, not the side). i've seen people mount amps on the bottom of there parcel shelf before, its another option..

hope this helps.


1991 Wide Arched Rieger Scirocco.....

Good things come to those who wait!!!!

User avatar
fonzooorooo
Posts:429
Joined:Sun May 17, 2009 9:23 am
fill in the right answer:10
Location:NW Leics

Re: Amp problems

Post by fonzooorooo » Wed Feb 16, 2011 5:08 pm

Have any fuses blown on the amp? Whip them out and check first. If one's gone, DON'T just change it...

For the time it takes to do, I'd take the amp out of the car, and take the top cover off the amp. Then you'll see if there's any sign of water inside.

If it looks wet, dry it out THOROUGHLY. (Under a lamp, on a radiator or similar - better to use less heat for a longer time.)

If there's no sign of water, and no obvious burned looking components, pop it back together, and replace any fuses that've blown.

Wire it back up and see if it works. If only the 1 channel still works, test by swapping input cables, and the 1 known good speaker cable into the channels that don't work. That'll point you in the direction of any wiring that needs looking at... or confirm whether the amp's dead/alive.



User avatar
fonzooorooo
Posts:429
Joined:Sun May 17, 2009 9:23 am
fill in the right answer:10
Location:NW Leics

Re: Amp problems

Post by fonzooorooo » Wed Feb 16, 2011 5:17 pm

as for the other part of your query: whether the 6x9"s and 12" sub'll be happy off the amp...

It depends how loud you're playing it... If it's just a "decent sounding car stereo" - able to play above the road noise, but never turned up properly loud, the alpine amp should be OK. I' like more power available for the sub though.
The JBL amp looks more appropriate for a 200W sub and loud 6x9"s.

If you're looking to play the system LOUD, then to avoid clipping, I'd be looking to run 300 to 400W into a 200W sub... that'll still be delivering "clean" power when you hear the sub distort (whereupon you turn it down!)



G Beats
Posts:1050
Joined:Sun Jun 21, 2009 12:19 am
fill in the right answer:10

Re: Amp problems

Post by G Beats » Thu Feb 17, 2011 2:02 am

Chaps wrote:Few questions:
1, how wet did the amp get exactly? there is a big difference between a small splash (drops) and a big splash (bucket full)? well it was very windy and raining quit hard so i would say small splash (drops)
2, was the amp on at the time that it got wet? no
3, was the setup working 100% before it got wet? yes except the head unit balance has never had the balance working the back 2 speekers it is alpine and i have it since new 2008 all so the amp and the bass speeker' i have a brand new inphase head unit i can fit if you you think this will help?
4, how is the amp currently wired up? do you got a photo of your set up you can put up. it is not bridaged it had the 6x9s and the bass box running off it' the amp is powerd str8 to the battery with the phono leads going to the head unit' grounded in the boot the amp.


As to the products you've put together below (including new JBL amp)... yes it will all work together but your amp would be running at max output. You need to measure your sub box to make sure the amp will be able to mount on it, from looking it should fit on it somehow (maybe on the back of it, not the side). i've seen people mount amps on the bottom of there parcel shelf before, its another option..as for the amp i was thinking of the i have all ready if i can get working again' or could recomend me as the jbl will be running at max all so what rms wats iam looking to the jbl 6x9s and the base box? many thanx for your help its more then apperctied


hope this helps.


G Beats.Been into MK 2 V.W Sciroccos since 98.Now on my fourth MK 2 Scirocco. R.I.P two MK 2 Scala DX Engine's.Sold GT 2.

G Beats
Posts:1050
Joined:Sun Jun 21, 2009 12:19 am
fill in the right answer:10

Re: Amp problems

Post by G Beats » Thu Feb 17, 2011 2:11 am

fonzooorooo wrote:Have any fuses blown on the amp? Whip them out and check first. If one's gone, DON'T just change it...

For the time it takes to do, I'd take the amp out of the car, and take the top cover off the amp. Then you'll see if there's any sign of water inside.

If it looks wet, dry it out THOROUGHLY. (Under a lamp, on a radiator or similar - better to use less heat for a longer time.)

If there's no sign of water, and no obvious burned looking components, pop it back together, and replace any fuses that've blown.

Wire it back up and see if it works. If only the 1 channel still works, test by swapping input cables, and the 1 known good speaker cable into the channels that don't work. That'll point you in the direction of any wiring that needs looking at or confirm whether the amp's dead/alive.

ok i will look at this today some time and let you know what find ok many thanx


G Beats.Been into MK 2 V.W Sciroccos since 98.Now on my fourth MK 2 Scirocco. R.I.P two MK 2 Scala DX Engine's.Sold GT 2.

G Beats
Posts:1050
Joined:Sun Jun 21, 2009 12:19 am
fill in the right answer:10

Re: Amp problems

Post by G Beats » Thu Feb 17, 2011 2:27 am

fonzooorooo wrote:as for the other part of your query: whether the 6x9"s and 12" sub'll be happy off the amp...

It depends how loud you're playing it... If it's just a "decent sounding car stereo" - able to play above the road noise, but never turned up properly loud, the alpine amp should be OK. I' like more power available for the sub though.
The JBL amp looks more appropriate for a 200W sub and loud 6x9"s.

If you're looking to play the system LOUD, then to avoid clipping, I'd be looking to run 300 to 400W into a 200W sub... that'll still be delivering "clean" power when you hear the sub distort (whereupon you turn it down!)
as for what u say about this i would like the amp to run the 2 things propely so would be looking for a better amp to run them' but chaps off says i would maxing that jbl amp to run the 6x9s and the bass box' so is the 300 to 400w you say is just to run the sub? as i have 6x9s to run off a amp as well ok ' so what amp would how much rms w would you have to run the 2 things i ask about many thanx


G Beats.Been into MK 2 V.W Sciroccos since 98.Now on my fourth MK 2 Scirocco. R.I.P two MK 2 Scala DX Engine's.Sold GT 2.

User avatar
fonzooorooo
Posts:429
Joined:Sun May 17, 2009 9:23 am
fill in the right answer:10
Location:NW Leics

Re: Amp problems

Post by fonzooorooo » Thu Feb 17, 2011 8:45 am

geebeats wrote:
fonzooorooo wrote:as for the other part of your query: whether the 6x9"s and 12" sub'll be happy off the amp...

It depends how loud you're playing it... If it's just a "decent sounding car stereo" - able to play above the road noise, but never turned up properly loud, the alpine amp should be OK. I' like more power available for the sub though.
The JBL amp looks more appropriate for a 200W sub and loud 6x9"s.

If you're looking to play the system LOUD, then to avoid clipping, I'd be looking to run 300 to 400W into a 200W sub... that'll still be delivering "clean" power when you hear the sub distort (whereupon you turn it down!)
as for what u say about this i would like the amp to run the 2 things propely so would be looking for a better amp to run them' but chaps off says i would maxing that jbl amp to run the 6x9s and the bass box' so is the 300 to 400w you say is just to run the sub? as i have 6x9s to run off a amp as well ok ' so what amp would how much rms w would you have to run the 2 things i ask about many thanx
Bear in mind that all the wattage ratings on audio gear is if it's turned right up!
Yes, If you plan on playing it LOUD, then 300W or more for a 200W sub is about right. (If it's not getting cranked up, it makes no difference - as long as there's enough clean power available for the volume you're running it at. (If you listen to music at 15 watts, a 25 watt amp is enough!)

If it's a 4 channel amp, you'd be bridging 2 channels for the sub, and running the other 2 for the 6x9"s. Hence: Take the total pwer output and divide by 4. That gives you the wattage per channel. Double this, and that's what the sub will get.



G Beats
Posts:1050
Joined:Sun Jun 21, 2009 12:19 am
fill in the right answer:10

Re: Amp problems

Post by G Beats » Thu Feb 17, 2011 10:26 pm

so i take this amp will not work on the set up i have /? anyways i looked at the amp and the fuse is fine it had a bit of condation on it wich i wiped off with tisue all leads and conections are fine ' but to be honest i think had the amp as had it and plus it will not run these----


http://www.caraudiodiscount.com/speaker ... 11859.html


http://uk.shopping.com/Alpine-SWE-1241/info


so what amp would be good to? as for the jbl amp this is what chaps said about it----


As to the products you've put together below (including new JBL amp)... yes it will all work together but your amp would be running at max output.

what do u think on all of this?


G Beats.Been into MK 2 V.W Sciroccos since 98.Now on my fourth MK 2 Scirocco. R.I.P two MK 2 Scala DX Engine's.Sold GT 2.

G Beats
Posts:1050
Joined:Sun Jun 21, 2009 12:19 am
fill in the right answer:10

Re: Amp problems

Post by G Beats » Thu Feb 17, 2011 10:47 pm

geebeats wrote:so i take this amp will not work on the set up i have /? anyways i looked at the amp and the fuse is fine it had a bit of condation on it wich i wiped off with tisue all leads and conections are fine ' but to be honest i think had the amp as had it and plus it will not run these----


http://www.caraudiodiscount.com/speaker ... 11859.html


http://uk.shopping.com/Alpine-SWE-1241/info


so what amp would be good to? as for the jbl amp this is what chaps said about it----


As to the products you've put together below (including new JBL amp)... yes it will all work together but your amp would be running at max output.

what do u think on all of this?
Last edited by G Beats on Fri Feb 18, 2011 3:35 am, edited 2 times in total.


G Beats.Been into MK 2 V.W Sciroccos since 98.Now on my fourth MK 2 Scirocco. R.I.P two MK 2 Scala DX Engine's.Sold GT 2.

G Beats
Posts:1050
Joined:Sun Jun 21, 2009 12:19 am
fill in the right answer:10

Re: Amp problems

Post by G Beats » Thu Feb 17, 2011 11:29 pm

geebeats wrote:
geebeats wrote:so i take this amp will not work on the set up i have /? anyways i looked at the amp and the fuse is fine it had a bit of condation on it wich i wiped off with tisue all leads and conections are fine ' but to be honest i think had the amp as had it and plus it will not run these----


http://www.caraudiodiscount.com/speaker ... 11859.html


http://uk.shopping.com/Alpine-SWE-1241/info


so what amp would be good to? as for the jbl amp this is what chaps said about it----


As to the products you've put together below (including new JBL amp)... yes it will all work together but your amp would be running at max output.

what do u think on all of this?


would these run what i ask====






http://cgi.ebay.de/BLUE-COUGAR-4-CHANNE ... 4868wt_919


http://cgi.ebay.co.uk/COUGAR-4-CHANNEL- ... 0733846284?

pt=UK_Audio_TV_Electronics_In_Car_Entertainment_GPS_Car_Amplifiers_PP&hash=item3364c3330c#ht_4868wt_919

http://cgi.ebay.co.uk/AUNA-AMP-CH04-AMP ... 0440103436?

pt=UK_Audio_TV_Electronics_In_Car_Entertainment_GPS_Car_Amplifiers_PP&hash=item5197db9e0c#ht_4879wt_919



pt=UK_Audio_TV_Electronics_In_Car_Entertainment_GPS_Car_Amplifiers_PP&hash=item5197991b1a#ht_2089wt_976


http://cgi.ebay.co.uk/COUGAR-1600W-MOSF ... 4868wt_919




pt=UK_Audio_TV_Electronics_In_Car_Entertainment_GPS_Car_Amplifiers_PP&hash=item33652e35f8#ht_4879wt_919

http://cgi.ebay.co.uk/AUNA-AB450-CAR-HI ... 4868wt_919


http://cgi.ebay.co.uk/FLI-FU720-4-4-mul ... _938wt_881



http://cgi.ebay.co.uk/FLI-900s-4-multi- ... 1026wt_881


http://cgi.ebay.co.uk/EDGE-ED7800-4-3-2 ... nics_In_Ca



pt=UK_Audio_TV_Electronics_In_Car_Entertainment_GPS_Car_Amplifiers_PP&hash=item255316dd7d#ht_1628wt_982


http://cgi.ebay.co.uk/JBL-GTO-4000-600W ... dio_TV_Ele


http://www.caraudiodiscount.com/amplifi ... 17205.html


http://caraudiosecurity.com/shop/produc ... /8448.html

http://www.bassjunkies.com/audio/crunch-gp4150


http://www.bassjunkies.com/audio/crunch-p1800-4


G Beats.Been into MK 2 V.W Sciroccos since 98.Now on my fourth MK 2 Scirocco. R.I.P two MK 2 Scala DX Engine's.Sold GT 2.

User avatar
fonzooorooo
Posts:429
Joined:Sun May 17, 2009 9:23 am
fill in the right answer:10
Location:NW Leics

Re: Amp problems

Post by fonzooorooo » Fri Feb 18, 2011 10:43 am

of the ones you've listed, this one looks the best - but it's a brand I've never heard of, so can't really recommend.

http://cgi.ebay.de/BLUE-COUGAR-4-CHANNE ... 4868wt_919

It will give you 125W for EACH 6x9" and 250W for your sub.

Only look at the RMS ratings. Ignore anything that doesn't say RMS.

You might be best off ringing a firm like bass junkies and asking their recommendations.

Honestly, it all comes down to how loud you want the music to play!



G Beats
Posts:1050
Joined:Sun Jun 21, 2009 12:19 am
fill in the right answer:10

Re: Amp problems

Post by G Beats » Sat Feb 19, 2011 6:12 am

ok i see' well here is some feed back on the amp--

http://www.nextag.co.uk/Amazon+Marketpl ... zukz17-htm


and i thought it is the amp as it is vg


G Beats.Been into MK 2 V.W Sciroccos since 98.Now on my fourth MK 2 Scirocco. R.I.P two MK 2 Scala DX Engine's.Sold GT 2.

G Beats
Posts:1050
Joined:Sun Jun 21, 2009 12:19 am
fill in the right answer:10

Re: Amp problems

Post by G Beats » Wed Jun 29, 2011 3:22 am

fonzooorooo wrote:of the ones you've listed, this one looks the best - but it's a brand I've never heard of, so can't really recommend.

http://cgi.ebay.de/BLUE-COUGAR-4-CHANNE ... 4868wt_919

It will give you 125W for EACH 6x9" and 250W for your sub.

Only look at the RMS ratings. Ignore anything that doesn't say RMS.

You might be best off ringing a firm like bass junkies and asking their recommendations.

Honestly, it all comes down to how loud you want the music to play!
ok the have sold of the blue cougar one how about this 1--

http://www.hifi-tower.co.uk/Auna-AMP-CH ... 3310_0.htm

380 rms ?


G Beats.Been into MK 2 V.W Sciroccos since 98.Now on my fourth MK 2 Scirocco. R.I.P two MK 2 Scala DX Engine's.Sold GT 2.

User avatar
fonzooorooo
Posts:429
Joined:Sun May 17, 2009 9:23 am
fill in the right answer:10
Location:NW Leics

Re: Amp problems

Post by fonzooorooo » Thu Jun 30, 2011 11:08 am

geebeats wrote:
fonzooorooo wrote:of the ones you've listed, this one looks the best - but it's a brand I've never heard of, so can't really recommend.

http://cgi.ebay.de/BLUE-COUGAR-4-CHANNE ... 4868wt_919

It will give you 125W for EACH 6x9" and 250W for your sub.

Only look at the RMS ratings. Ignore anything that doesn't say RMS.

You might be best off ringing a firm like bass junkies and asking their recommendations.

Honestly, it all comes down to how loud you want the music to play!
ok the have sold of the blue cougar one how about this 1--

http://www.hifi-tower.co.uk/Auna-AMP-CH ... 3310_0.htm

380 rms ?
So you bought the amp, don't like it and sold it?

That "Auna" you've linked to is 380W, so 95W per channel. (each 6x9" gets 95W and the sub gets 190W)

The power you actually get from these budget amps is going to be less than from a more expensive amp (which will have better quality components inside) even if they have the same rating in watts.

If you're not playing the system silly-loud, then any amp at this sort of power would be fine.

What is the rest of your system? (what headunit, front speakers, do you amp the front speakers?)
What music do you listen to?
How loud do you play it?